gio 500 Watt Scooter

No replies
metaljoe
Offline
Joined: 03/20/2012
Points: 3

Good Day All! I Have A Problem With My Gio 500 watt scooter! It was given to me and i had to do repairs to the wire harness and have a problem with it losing power to the motor but still showing power on the instruments! It seems to lose power after riding for awhile! If I turn off the power button and let it sit for 5 minutes then turn power button on it will go again but for how long is undetermined until it loses power to motor again! I have tried to bypass key switch and power switch but still have the same result! I am hoping someone can give me an idea if it is possibly the wire harness or the controller or maybe a motor problem! Any help or input on this matter would be greatly appreciated! There must be a reason why it loses power to the motor only and will not accellerate when cranking the throttle! Thanx!!!

__________________

MetalJoe

style="display:block"
data-ad-client="ca-pub-2401070691062219"
data-ad-slot="2079401426"
data-ad-format="auto">

Simply Car-free How to Pedal Toward Financial Freedom and a Healthier Life
Internal Combustion: How Corporations and Governments Addicted the World to Oil and Derailed the Alternatives
Transport Revolutions: Moving People and Freight Without Oil
Electric Bicycles: A Guide to Design and Use
e-Moto G3 Volt Silicon Electric Scooter Commute and get around town on the G3 Volt Electric Scooter from E-Moto.
JOLT!: The Impending Dominance Of The Electric Car And Why America Must Take Charge



Who's new

  • gsuhas
  • jefferyinman
  • bociaz
  • Camile1702
  • FantaisyRat
Customize This