Visforvoltage page consumes 100% CPU time for 10 seconds

1 reply [Last post]
AndY1's picture
Offline
Joined: 06/17/2008
Posts:
Points: 1071

It began some weeks ago, but on different computers, when the page is loading or when I'm exiting Firefox, CPU jumps to 100% for about 10 seconds and freezes Firefox. My Nokia E71 web browser isn't taking it kindly as well.

What is loading there, in the background?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
reikiman's picture
Offline
Joined: 11/19/2006
Posts:
Points: 8448
Re: Visforvoltage page consumes 100% CPU time for 10 seconds

There are various services which cause javascript blobs to load. At least one is at the end of the page.

By "take 100% of CPU" have you measured that with a performance analyzer? I'm asking because it might not be technically be doing 100% of CPU but instead making the browser wait for something and waiting can cause the busy cursor to pop up.

Looking at the javascript .. at the end of the page there's a call to Google's Analytics service that's there to report usage and traffic statistics. It's possible that call could take a "long" time depending on how busy Google's servers are in that moment. But it would be happening randomly rather than on every page load.

__________________

- David Herron, Green Transportation Examiner, Green Transportation Info, The Long Tail Pipe, Torque News, electric race news, davidherron.com, 7gen.com, What is Reiki
- EVT 4000, Charger bike (rebuilt), Vego 600sx (rebuilt), Electrified Electra Townie
- Lectra motorcycle, 1971 Karmann Ghia

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Short URL

Customize This