36 Volt Izip has lost power

4 replies [Last post]
blairg's picture
Offline
Joined: 03/21/2009
Posts:
Points: 50

My Izip running on 36 volts was running great until recently when it has lost significant power. It now has the performance of about a 24 volt. Anybody have any ideas why ?

Thanks

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Offline
Joined: 06/22/2009
Posts:
Points: 520
Re: 36 Volt Izip has lost power

The batteries may be defective, allowing the voltage to drop below 33 volts under load of accelleration.---Connect a good voltmeter, and measure voltage WHILE OPERATING it, preferably on a slight UPHILL climb.--Bob
PS: A good 36 volt, lead-acid battery will measure over 41 volts at full charge completion. (12 volt lead-acid batteries will measure over 13.6 volts at full charge completion.--

__________________

Robert M. Curry

blairg's picture
Offline
Joined: 03/21/2009
Posts:
Points: 50
Re: 36 Volt Izip has lost power

Thanks for the suggestion but I have two lipo batteries and one lead acid and the performance seems to be the same on all of them.

Any more ideas ?

blairg's picture
Offline
Joined: 03/21/2009
Posts:
Points: 50
Re: 36 Volt Izip has lost power

I took it apart and it had overheated and was burnt

Offline
Joined: 05/05/2010
Posts:
Points: 15
Re: 36 Volt Izip has lost power

What was 'it', the controller?

__________________

[1]Hao Shun e-bike [2]Aprilia Enjoy Racing e-bike [3]eLation V2 e-bike kit on Trek 4100

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Short URL

Customize This