2x Chargers unprogrammable/unflashable ?

33 posts / 0 new
Last post
ofx210p
Offline
Last seen: 4 years 8 months ago
Joined: Monday, October 20, 2008 - 03:22
Points: 377
2x Chargers unprogrammable/unflashable ?

Long story short
My new vectrix charger has been misbehaving since day one some weeks back.

Been given multiple reasons for the failure of the systems
Firstly it will sync with use (so i used it every evening letting it charge daily)
Then i was told to just upgrade the systems firmware.
Tried to update the firmware and all systems updated except the charger.
I was then told to detach the charger - leave for a while then re-attach and try to upgrade firmware again.

This still failed.

So a replacement charger was sent.

Fitted it today.
All systems are go and software revisions for ICM - DASH - Motor controller etc all show in the Vectrix diag software except the Charger and it still fails to program exiting with a DM15 failure.

If anyone has a clue now i'll be happy to listen as I have had enough now.

Cheers

Chris

ofx210p
Offline
Last seen: 4 years 8 months ago
Joined: Monday, October 20, 2008 - 03:22
Points: 377
Re: 2x Chargers unprogrammable/unflashable ?

Software revisions

software revisions.closer.jpg

Programming failure
dm15fail.jpg

Charger plugs do they all have additional earthing wires ?
charger plugs.JPG

lebemax
Offline
Last seen: 8 years 8 months ago
Joined: Monday, March 7, 2011 - 11:33
Points: 5
Re: 2x Chargers unprogrammable/unflashable ?

Charger communication might be interrupted by temp sensors on the battery pack so originally the charger might be ok. Don't think your second charger failed too. Do you have any readings from the summary page ( I mean temperature ) in the diagnostic programme?

ofx210p
Offline
Last seen: 4 years 8 months ago
Joined: Monday, October 20, 2008 - 03:22
Points: 377
Re: 2x Chargers unprogrammable/unflashable ?

Interesting..... do you mean if the temp sensors aren't connected ?

I'll check now and get back to you.

ofx210p
Offline
Last seen: 4 years 8 months ago
Joined: Monday, October 20, 2008 - 03:22
Points: 377
Re: 2x Chargers unprogrammable/unflashable ?

This is from the summary page

My bike when powered up and left brake hit - shows 21degrees and 207 whatever that means

But the summary here shows something entirely different

vectrix temps-1.JPG

vectrixcr
Offline
Last seen: 5 years 3 months ago
Joined: Friday, October 1, 2010 - 12:04
Points: 12
Re: 2x Chargers unprogrammable/unflashable ?

accenda lo scooter con la scooterdiag collegato, poi vada nella sessione firmware e poi stacchi prima lo spinotto del sensore di temperature anteriore per capirsi quello sotto la chiave attenda qualche secondo e veda se il la scritta del charger diventa verde, se si allora il problema e il sensore di temperatura anteriore altrimenti stacchi anche il sensore di temperatura posteriore e verifichi se diventa verde la scritta del charger, se diventa verde allora per verifica attacchi il sensore di temp anteriore cosi facendo si capisce quale sentore da problemi, con questa procedure la scritta non diventa verde e molto probabile che si il charger .
P.S. scusate se non scrivo in inglese ma non lo conosco

ofx210p
Offline
Last seen: 4 years 8 months ago
Joined: Monday, October 20, 2008 - 03:22
Points: 377
Re: 2x Chargers unprogrammable/unflashable ?

Thanks for that

Google translate :=

turn on the scooter with scooterdiag connected, then go in the session
firmware and then pulls the plug of the first temperature sensor front
to understand that under the key wait a few seconds and see if the
written charger turns green, then if the problem and the sensor
Temperature also detach the front otherwise the temperature sensor
back and check if the writing of the charger turns green, if it becomes
Green then attacks the sensor for verification of time before doing so
we understand that hint of problems with this procedure is not the word
turns green and is very likely that the charger.
P.S. sorry if I do not write in English but do not know

i will try later today after work (presently 8:13am here) GMT+12

antiscab
Offline
Last seen: 1 week 5 days ago
Joined: Saturday, July 7, 2007 - 23:55
Points: 1686
Re: 2x Chargers unprogrammable/unflashable ?

My bike when powered up and left brake hit - shows 21degrees and 207 whatever that means

21 deg C is the temperature shown when the temp sensors haven't reported the temperature yet.

Given the diagnostic software also isn't reporting, would suggest the temp sensors aren't working at all.

However, failed temp sensors won't stop the charger from being flashed.

A fault in the CAN bus could cause this though. I wonder if theres a plug come loose somewhere.....

Matt

Daily Ride:
2007 Vectrix, modified with 42 x Thundersky 60Ah
Vectrix 60Ah Lithium Tyres Fuel Registration Insurance cycle analyst 2 x TC Charger & MC
conversion

ofx210p
Offline
Last seen: 4 years 8 months ago
Joined: Monday, October 20, 2008 - 03:22
Points: 377
Re: 2x Chargers unprogrammable/unflashable ?

Thanks matt

I'll be diving into the bike sometime next week at this rate.

Unfortunately just had builders in to re-model bits of the house so its all a bit crazy

however i'll take a look at the manual for how to get all the covers off and get to the temp sensors. I wonder if they are just NTC or PTC resistive thermal probes that i can buy cheaply from RS components.

Its Interesting you think it could be a can bus issue but the system never reports any issues.

I've unplugged the replacement charger as it would boot - go to 1700w and then after 20seconds would shut down.Checking the meter later showed me it was not doing anything useful bar getting slightly warm to the touch.

The original one which only runs at 500w is plugged back in again - at least its doing 'something' with regard to charging.

Cheers again

Chris

vectrixcr
Offline
Last seen: 5 years 3 months ago
Joined: Friday, October 1, 2010 - 12:04
Points: 12
Re: 2x Chargers unprogrammable/unflashable ?

also to me when I had the broken sensor of anterior temperature, from diagnostic I didn't see the charger and the batteries monitor, then with the diagnostic connected and the turned on scooter I have scollegato a sensor of temperature to the time and the diagnostic one to started to it sees again the everything again

ferdinando

ofx210p
Offline
Last seen: 4 years 8 months ago
Joined: Monday, October 20, 2008 - 03:22
Points: 377
Re: 2x Chargers unprogrammable/unflashable ?

Eureka .... well kinda

Ok with all the help and pointers you've all been giving me (thanks everyone) i took the bike apart today down to battery level.

Found the connectors for the front and rear temp sensors. Disconnected them and then tried to flash the battery charger. It worked. Charger was programmed ok. But when the bike had the sensors plugged back in and the software refused to see the charger again.

Interestingly with the sensors unplugged and the bike plugged into the mains it goes into full-on charging mode, however after about 20 seconds the whole bike shuts down. I assume this is a failsafe because it can't see the sensors anymore. But then again - this charger has always done that - next thing to try will be to put old charger in and see what that does as that charger seems to charge in a completely different way (500w mains draw, 10 mins on 10 mins off repeated ad infinitum)

Anyhow - i'm on a bit of a high now as I was getting quite depressed about this so irrespective of anything - it feels like progress.

One thing that helpped was this post
http://visforvoltage.org/forum/9048-fuel-gage-morphed-efficiency-gage

Now i just have to discover if its just the temp sensor circuit board or temp sensors or something much bigger elsewhere like canbus issues ? More testing and i'll fill you all in later - its 11:20pm here.
Cheers
Chris

ofx210p
Offline
Last seen: 4 years 8 months ago
Joined: Monday, October 20, 2008 - 03:22
Points: 377
Re: 2x Chargers unprogrammable/unflashable ?

Ok.... managed to find some time today to re-flash the charger and controller with older firmwares. Thanks Matt for supplying those.
Then spent about 2 hrs re-assembling the bike. That front panel around the charger is an absolute pig isnt it !

Anyhow - put the bike on charge and it worked for the first time ever and it went through the standard EE EC CP EQ charge process (please note i just guessed at those)

So bike is fully charged and i took for a ride. Starting voltage from finish charge was 143v - 25km later i could feel the batteries getting weaker and had a few Busult's displayed on the screen but other than that reasonably happy with it. and the final voltage upon plugging it in to the diagnostics were around 125v.

Obviously the biggest worry is that whizzing along with both battery and temp lights flashing continuously is a little off putting, but hopefully because it is winter (9 degrees C daily) the batteries aren't going to get too hot and i am sure that at least getting the batteries charged properly is going to help more than the mess that was happening before.

Sadly nobody (Charles ex vectrix usa - nor Dana in USA ) seem to have the answers to how to diagnose the temp sensors or temp sensor board. Obviously from my perspective I'd prefer the temp sensor board is faulty as that would be easier to replace than all the sensors which are interspersed within the battery pack.

So that's where its at. Now i'm just eager to get some kms under the belt to try to improve range and see if i can get this thing to work and back (36km round trip) without recharging at work daily.

Again - thanks to everyone who has helped on here including Charles, Dana, Matt, and oobflyer for posting this link http://visforvoltage.org/forum/9048-fuel-gage-morphed-efficiency-gage which helped me recognise the symptoms.

So.... anyone know how the temp sensors on this works ?

Thanks

Chris

turok
turok's picture
Offline
Last seen: 1 year 4 months ago
Joined: Wednesday, March 11, 2009 - 00:27
Points: 338
Re: 2x Chargers unprogrammable/unflashable ?

Hi..

Long time no see..
You will usually see me when my vectrix goes bad again.

I have had my vectrix for a lot of years, and everything has been broken except for the batteries :)

In fact, this is my second vectrix, as my first one has been crushed under a truck, but I'm fine now thank you :-)

This second one, I've been riding for a few months now, and yesterday my MC gave up. Burned the motor connection terminals.
I had a spare MC from the accident bike, and swapped it out (it had the right firmware on it), then recalibrated, and off it went, but the fuel gauge had turned into a voltage gauge (as seen in other cases, so I already suspected something went wrong.)
When I came home, and plugged the bike in, it wouldn't charge. I reconnected the diagnostics software, and it seems that the charger isn't recognized any more, with the same error like in this post, "did not receive DM15..."

I'm lost, I fear my charger is now also dead..
I'm not sure though.
Which connector would be the temperature sensors to disconnect? (It won't hurt to try that I guess..)

any other ideas/advice?

thanks

Dirk

"doing nothin = doing nothing wrong" is invalid when the subject is environment

R
R's picture
Offline
Last seen: 3 weeks 5 days ago
Joined: Thursday, June 18, 2009 - 09:46
Points: 1758
Re: 2x Chargers unprogrammable/unflashable ?

Hi turok, Nice to hear from you!
Death Symptoms, but strange.
The BC is dead after replacing the MC? Maybe a connection is loose after the replacement?

turok
turok's picture
Offline
Last seen: 1 year 4 months ago
Joined: Wednesday, March 11, 2009 - 00:27
Points: 338
Re: 2x Chargers unprogrammable/unflashable ?

Nice to see you too Roger:-)

Yes that's it basically, death after replacing MC.

First thing I did today was unplugging and replugging all the connections, including the ones in the front at the charger, but it didn't help.

I have to be honest though: I don't believe in the ICL, so I usually plug the battery (blue Anderson connector?) straight in. Maybe that's it? It finally bit me back?

Do you have any idea what or where the connector of the temperature sensors is?

And another theory: could it be that the MC that I put in (the one from the accident) causes the error?

thx..

"doing nothin = doing nothing wrong" is invalid when the subject is environment

Archi13
Archi13's picture
Offline
Last seen: 1 year 6 months ago
Joined: Saturday, October 27, 2012 - 14:31
Points: 54
Re: 2x Chargers unprogrammable/unflashable ?

Hello Turok,
Your charger have nothing, the problem is in your motor controller, I think that you have connect your mc without inrush limiter, you can use a bulb lamp instead. You can repair your Motor controller board, you must replace the little central fuse near the square plug.MC board-1.jpg (1.67 MB)
I have a french post where I explain my repair:
http://vectrix.lorsignol.fr/index.php?option=com_agora&task=topic&id=194&Itemid=11

Good repair.

R
R's picture
Offline
Last seen: 3 weeks 5 days ago
Joined: Thursday, June 18, 2009 - 09:46
Points: 1758
Re: 2x Chargers unprogrammable/unflashable ?

I don't believe in the ICL, so I usually plug the battery (blue Anderson connector?) straight in. Maybe that's it? It finally bit me back?

So, Turok... Do You believe in Elvis?
Thanks Archi13 for the tip, it makes sense. Plugging the blue Anderson connector without the ICL allows a hurricane of electricity to flow into the MC, sometimes devastating critical components. Try to look for "that" possible death fuse ( not the main fuse: if the main fuse blows the vectrix does not turn on at all)

The ICL reduces that devastating electrical hurricane to a controlled flow of energy.

I suggest this post is added to the collaborative handbook.

turok
turok's picture
Offline
Last seen: 1 year 4 months ago
Joined: Wednesday, March 11, 2009 - 00:27
Points: 338
Re: 2x Chargers unprogrammable/unflashable ?

I do believe Elvis is dead and so is something in my V:)

Thanks for the tip, I will check all the 40A fuses, but I wasn't considering them to be faulty, because I thought I would see a "Capcur" error on the dashboard then.
And it does drive 100% fine.

But I'll keep you informed ;)

Dirk

"doing nothin = doing nothing wrong" is invalid when the subject is environment

Archi13
Archi13's picture
Offline
Last seen: 1 year 6 months ago
Joined: Saturday, October 27, 2012 - 14:31
Points: 54
Re: 2x Chargers unprogrammable/unflashable ?

Hello Turok,
when the scooter work with the strange fuel gauge (go down in accelerate and go up when stop) and your charger don't work, the problem is on the MC board, change the little fuse 25A 250v.
Regards.

R
R's picture
Offline
Last seen: 3 weeks 5 days ago
Joined: Thursday, June 18, 2009 - 09:46
Points: 1758
Re: 2x Chargers unprogrammable/unflashable ?

The symptoms:

So as I said on another topic , the symptoms are a gauge that goes down to each acceleration and going back as soon as you release the throttle and the inability to recharge .

One that interests us is the central fuse near the white plug that goes to the charger , 25A 250Volts label .
Do not hesitate to scratch the surface in the corner fuses to test the continuity if not impossible to measure anything .

There are many fuses on the Board. The Capcur fuses:

Motor controller suspect.jpg
IMG_3525.jpg

The Other Fuses that interests Turok:
Fuses.jpg

turok
turok's picture
Offline
Last seen: 1 year 4 months ago
Joined: Wednesday, March 11, 2009 - 00:27
Points: 338
Re: 2x Chargers unprogrammable/unflashable ?

Thanks both, I hadn't even noticed these 25A fuses..

I'll try to swap them (or the ones that don't work.)

d

"doing nothin = doing nothing wrong" is invalid when the subject is environment

turok
turok's picture
Offline
Last seen: 1 year 4 months ago
Joined: Wednesday, March 11, 2009 - 00:27
Points: 338
Re: 2x Chargers unprogrammable/unflashable ?

Archi13 and R,

You are both geniuses (or geniis)!

I was really sweating when I plugged the V back in after replacing both the 25A fuses, but it charges.

I owe you guys, big time!

Kudos!!! Merci bien!!

d

"doing nothin = doing nothing wrong" is invalid when the subject is environment

R
R's picture
Offline
Last seen: 3 weeks 5 days ago
Joined: Thursday, June 18, 2009 - 09:46
Points: 1758
Re: 2x Chargers unprogrammable/unflashable ?

Thanks Archi for pointing put the problem. Great turok, well done! did you take pictures?

Archi13
Archi13's picture
Offline
Last seen: 1 year 6 months ago
Joined: Saturday, October 27, 2012 - 14:31
Points: 54
Re: 2x Chargers unprogrammable/unflashable ?

A vectrix back on the road, that is genious.

Kocho
Offline
Last seen: 4 years 1 month ago
Joined: Friday, March 21, 2014 - 21:05
Points: 488
Re: 2x Chargers unprogrammable/unflashable ?

-- removed --

turok
turok's picture
Offline
Last seen: 1 year 4 months ago
Joined: Wednesday, March 11, 2009 - 00:27
Points: 338
Re: 2x Chargers unprogrammable/unflashable ?

This is a pic of the old MC.

2014-03-19-16.19.39.jpg

As you can see, the terminals are toast.

I'm not sure why this happened though. I have two theories:

- There could have been a bad connection (I built this bike from parts, and maybe I didnt fasten the screws enough)

- or, it could be because lately the "Capcur" error appeared. I didn't have the time to look at it, so I continued driving to work for a few days. (allthough barely touching the throttle at all)

The question is: what killed what??

Because now, 2 or 3 days after changing the MC, I get the same error (capcur) again!

Any ideas on this?

"doing nothin = doing nothing wrong" is invalid when the subject is environment

antiscab
Offline
Last seen: 1 week 5 days ago
Joined: Saturday, July 7, 2007 - 23:55
Points: 1686
Re: 2x Chargers unprogrammable/unflashable ?

As you can see, the terminals are toast.

I'm not sure why this happened though.

Long story short:

those studs are made of mild steel, plated with nickle - marginal electrical conductor, better thermal conductor
basically every time you accelerate the studs get hot, but then cool down quickly = many thermal cycles

the brass ring on the board does not go all the way through, and the board itself is compressible

That MC is likely repairable, possibly even for free

if you feel like trying, look up antiscab on youtube and look for MC repair tutorial

If you do feel up to it, I'd be happy to take a look (shipping both ways europe to Australia is not cheap though)

If the IGBT is dead, it can be replaced

sorting out the cap cur message is trickier - your caps and their fuses are probably fine, its the sensing circuit that is blown

Matt

Daily Ride:
2007 Vectrix, modified with 42 x Thundersky 60Ah
Vectrix 60Ah Lithium Tyres Fuel Registration Insurance cycle analyst 2 x TC Charger & MC
conversion

turok
turok's picture
Offline
Last seen: 1 year 4 months ago
Joined: Wednesday, March 11, 2009 - 00:27
Points: 338
Re: 2x Chargers unprogrammable/unflashable ?

Thanks for the explanation Matt,

Before I swapped out the MC, after a "caphot" error, the "capcur" error had come on and stayed, and then a few days later those terminals burned out. (So I automatically thought one influenced the other)

Now (after MC swap), the "capcur" appears and dissapears.
Maybe you can derive conclusions from that fact.

Just curious, that sensing circuit, is it on the MC board itself?

How important is this error in the case it is the sensing circuit? Does it hurt to keep driving?
(I think I read somewhere that if it's one of the 40A fuses, the load goes to the other capacitors)

dirk

"doing nothin = doing nothing wrong" is invalid when the subject is environment

Archi13
Archi13's picture
Offline
Last seen: 1 year 6 months ago
Joined: Saturday, October 27, 2012 - 14:31
Points: 54
Re: 2x Chargers unprogrammable/unflashable ?

Hello Turok,
have you clean (you thoroughly clean with glass paper) the three connectors on the motor wires because if your old MC is like on the picture I think that the connector are on the same state, the best is to change the three connections and in this time you can see the quality from wire copper it must be clean and not black. In this current intensity the connection must be perfect and you must have the same minimum resistance on all wires.

Archi

turok
turok's picture
Offline
Last seen: 1 year 4 months ago
Joined: Wednesday, March 11, 2009 - 00:27
Points: 338
Re: 2x Chargers unprogrammable/unflashable ?

Merci Archi,

That makes a lot of sense. I didn't even look at the connectors to be honest.
To me, the vectrix is an everyday commuter, I love it, but also I need it every day, so I swapped the MC in about 4 hours after work, without even knowing where to start :)

I'll clean them asap..

"doing nothin = doing nothing wrong" is invalid when the subject is environment

R
R's picture
Offline
Last seen: 3 weeks 5 days ago
Joined: Thursday, June 18, 2009 - 09:46
Points: 1758
Re: 2x Chargers unprogrammable/unflashable ?

Hi Turok,
Archi is right again! If you don't replace the connectors, at least consider the possibility of installing a temperature sensor, to monitor the temperature around this board area. Will you repair the damaged MC? It is a 1500 Euro replacement component, it is really worth recovering it.

Pages

Log in or register to post comments


Who's online

There are currently 0 users online.

Who's new

  • hippidave
  • rvair19
  • Nicosp
  • VoltLurker
  • Greatwhite

Customize This