Schwinn Missle FS issue

4 replies [Last post]
Fluid72
Offline
Joined: 05/04/2010
Points: 21

I purchased new battries about 1.5 years ago. I had no issues until just this season (after the winter) I removed the scooter from storage and it ran fine (a little slow but still ran) I laid it down in the back of my truck, took it to the shore, removed it from the truck, went to go and the scooter just sputtered and surged then just died I now get nothing. The charger says green for charged and the light on the scooter is green. Any ideas as to where to start?

thanks!!!!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
strawhistle
Offline
Joined: 03/10/2008
Points: 340
Re: Schwinn Missle FS issue

Is the battery a lead acid battery? laying the battery on its side will let the acid out and leave the battery with no way to generate a voltage LaTeR

__________________

thank GOD I wake up above ground !!!!

Fluid72
Offline
Joined: 05/04/2010
Points: 21
Re: Schwinn Missle FS issue

Nope these are sealed scooter batteries.

e-doggies
e-doggies's picture
Offline
Joined: 12/30/2007
Points: 280
Re: Schwinn Missle FS issue

Fluid72 wrote:

...and the scooter just sputtered and surged then just died I now get nothing...

Sounds like it could be a connection issue. Do you have a voltmeter to help in diagnostics?

Start at the battery and check each connection. Work your way thru all the wiring all the way to the motor if necessary. Don't assume soldered joints are electrically well-connected. I've seen many Currie factory packs that are soldered at the tabs with a glob of "cold" solder on top, but still had a very wiggly connection. I'd also check the fuse and fuse holder carefully. Perhaps one or more connections rattled loose during the trip in your truck?

Please let us know what you find.

Huddy
Offline
Joined: 08/31/2013
Points: 22
Re: Schwinn Missle FS issue

I just have just acquired 2 missle fs's. I purchesd new batteries and chargers. When I turn the scooter and have the light and plugged into the charger andopen up the throttle I grt power to the motors. however when I unplug the scooter from the charger, I have no power. Does the scooter have to be connected or does it run on 1. I have had no luck on finding a manual online. Am I doing something wrong with the power supply? Help thanks
-

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

style="display:block"
data-ad-client="ca-pub-2401070691062219"
data-ad-slot="2079401426"
data-ad-format="auto">

Who Killed the Electric Car? Essential documentary explaining what happened the last time electric cars were killed



Who's new

  • sdf2000
  • Kile
  • Buffalo Chip
  • Mr Modify
  • el_sako

Customize This