XM-3150

43 posts / 0 new
Last post
MEroller
MEroller's picture
Offline
Last seen: 1 year 7 months ago
Joined: Monday, September 26, 2011 - 09:24
Points: 847
Re: XM-3150

That sounds like one of the hall switches that reports rotor position to the controller has conked out on you. They can replaced with similar types, but opening up a hub motor is not for the faint of heart. Then again, it does not require witchcraft either :-)

With one hall sensor inoperative it feels somewhat like a misfiring cylinder in an IC-engine, and might even sound similar, as the controller simply does not know what to do until it gets another vaild Hall signal and then thumps back to life.

My rides:
2017 Zero S ZF6.5 11kW, erider Thunder 5kW

Quintar
Offline
Last seen: 7 years 2 months ago
Joined: Wednesday, July 27, 2011 - 16:16
Points: 19
Re: XM-3150

Funny, I was going to put in my description that it almost feels like a misfiring cylinder! Hopefully that's it because replacing a bad hall sensor sounds way cheaper and easier than getting a whole new controller and trying to figure out the correct wiring. From reading the description of Chasbro's problem above it seems like it's pretty easy to check the hall sensors:

"I investigated the hall sensors. I made a checker from a radio shack “learning lab”. All showed good and it was fun at watching the LEDs blink. Each bank (or group) appears to have what they call 120 degree hall spacing (the 3 LEDs are neither all off or all on at the same time). And the two banks are staggered one pole apart. So every three degrees of rear wheel rotation, one of the six LEDs changes state."

I'll read up on that, it doesn't sound like he took the hub motor apart to check the sensors? I guess you can access the wires coming out of the motor someplace? I'll see if I can find a schematic for building a checker someplace. though it sounds like you just need to hook an LED across each sensor wire...

LeftieBiker
Offline
Last seen: 7 months 3 weeks ago
Joined: Saturday, July 9, 2011 - 04:36
Points: 886
Re: XM-3150

If you need a motor and want other mechanical parts, I have an XM3000 for sale in upstate NY, with good batteries and, as far as I an tell, a good motor. It seems to have a blown controller. It has the 'sportier' body, so you might just want to put your controller (and maybe front brake) on my scooter...

Quintar
Offline
Last seen: 7 years 2 months ago
Joined: Wednesday, July 27, 2011 - 16:16
Points: 19
Re: XM-3150

So I finally got the scooter open and was able to check the hall sensors. I just took the electrical tape off of the connector going into the controller box and used a voltmeter to read from the red wire to each of the white blue and purple wires. I would get 0V and then 5V when i turned the wheel on each line. You can feel the wheel kinda hop from winding to winding as you turn it and the sensors would go from 0 to 5V every 6 hops and from what I could tell each sensor was staggered by 2 hops. Unless I was doing it wrong that seems to indicate that the senors are fine so I'm assuming that means I have a problem with the controller.

I tried opening the controller box but it seems sealed shut. I took the 4 screws out of each end plate but neither one will come off. I was hoping to find an obviously fried component I could replace but obviously I can't tell if I can't get it open. I'm not sure it would even be fixable anyway. If the controller needs to be replaced anyone have tips on where I can buy a new one?

Thanks

TeamSlacker
Offline
Last seen: 4 years 8 months ago
Joined: Monday, January 10, 2011 - 16:40
Points: 32
Re: XM-3150

The 2 side plates are sealed to main aluminum housing with just some black silicon, you should be able to pry them off. Once both side plates are loose, you have to pull out all the Philips screws in the heatsink, and the circuit board will slide out one side or the other.

I repaired 1 of these controllers by replacing the shorted FET's. You have to unsolder all of them to test since they are connected in parallel.

TeamSlacker
Offline
Last seen: 4 years 8 months ago
Joined: Monday, January 10, 2011 - 16:40
Points: 32
Re: XM-3150

dupe

LeftieBiker
Offline
Last seen: 7 months 3 weeks ago
Joined: Saturday, July 9, 2011 - 04:36
Points: 886
Re: XM-3150

My controller has what looks like two big plugs for the wiring to enter, but they don't seem to come off. Is it fake, or a real quick-connect setup?

I have seen new controllers for sale, but can't remember where. A web search should find them. I think they were either $150 or $200...

TeamSlacker
Offline
Last seen: 4 years 8 months ago
Joined: Monday, January 10, 2011 - 16:40
Points: 32
Re: XM-3150

It's been a couple months since I repaired the last one, but no need to remove the wires from those plugs from what I recall. Just leave all the wires in the side plate and take the whole side plate off and slide the circuit board out.

I used to see some for sale on Eb but haven't been watching lately. If I had to replace one, I'd probably put a Kelly controller in.

Quintar
Offline
Last seen: 7 years 2 months ago
Joined: Wednesday, July 27, 2011 - 16:16
Points: 19
Re: XM-3150

I got the controller open and it was very obvious that several of the mosfets were blown. there was scorching on the heatsink and several of the mosfets were cracked and the leads to them were melted...
I see that there are some ebay listings for 10 of these IRFB4310 power mosfets for $15. are there any special considerations with these or should I just be able to order any IRFB4310s and swap them out?

IMAG0131.jpg

looks like about 6 of them are bad. I figure replacing them should work fine since the scooter runs now with them bad so I don't think anything else is broken.

TeamSlacker
Offline
Last seen: 4 years 8 months ago
Joined: Monday, January 10, 2011 - 16:40
Points: 32
Re: XM-3150

You can't go just on looks. From what I recall three or four are in parallel. You will have to de solder and remove them from the circuit and test each one individually.
I looked at the numbers on the ones I could still read, and just ordered them from Digikey, as long as the numbers are the same, shouldn't matter where you get them from.
Your safest bet is to just order enough to replace them all at once. It's very possible that when one shorted in a 'parallel bank' others could have been weakend. The cheap route is to remove all, check them for shorting, and only replace the shorted ones. (which I did, but when I put it back together and powered it up the first time, a couple more shorted so I had to pull it apart again to replace those)

indago
Offline
Last seen: 8 years 1 week ago
Joined: Thursday, May 15, 2014 - 17:44
Points: 26
Re: XM-3150

I need to purchase a headlight lens for the XM-3150. I don't know if this lens is the same on some of the other models, but if someone here has a spare parts lens, I would appreciate a response.

Quintar
Offline
Last seen: 7 years 2 months ago
Joined: Wednesday, July 27, 2011 - 16:16
Points: 19
Re: XM-3150

So after replacing several of the mosfets and having them blow again as soon as I tried running the motor, I eventually gave up and ordered a Lyen 18 FET IRFB 4110 “Overclocker” controller like chasbro had done. Following the much appreciated instructions Chasbro left here I was able too hook it up and now the bike is running again. So thanks for that!

I was wondering though...the motor is now only using 3 phase wires on one set of it's windings. I can't seem to find anywhere how the two windings are set up. Some efun motors appear to have a high speed winding and a high torque winding that you can switch between. I think this one might be set up that way. But the newer ones seem to use the high torque winding to start and then switch on both windings at high speed? Anyway, it seems such a waste to leave all that copper in the motor unused. I'm not sure if the 2 windings are wye and delta or if they occupy every other tooth or if they are just identical windings overlaid on each other but with one having less turns and one having more turns...I'm wondering if anyone knows how this motor is wound and if it would be possible to connect up all 6 phase wires, like 2 pairs in series or parallel. I'm guessing that'd only be possible if they were identical layouts on top of each other or at least staggered on every other tooth...Seems like with more copper being used it'd reduce the resistance and help keep the motor cooler/allow it to take more amps? though it'd probably result in an intermediate mid torque, mid speed motor...

Also the diagnostic LED connector now no longer has anything to plug into anymore so my dash LEDs are non-functional. I don't mind the brake LED being off since that was blindingly annoying at night...but the red "on" LED might be helpful. I was thinking of connecting it to the +/- wires in the cycle analyst plug since I don't have one of those but that looks like it outputs 60V...Otherwise I guess I could tap into the 12V from the DC converter someplace. I'm hoping Chasbro figured something out.

Pages

Log in or register to post comments

Buy Ecotric bikes, get free accessories!


Who's online

There are currently 0 users online.

Who's new

  • fluffyrecomenda
  • terryfundak
  • Bence98007
  • OliverJohn2030
  • Jimmyjohn

Support V is for Voltage