scooter diagnostic not comunicating with Vectrix

12 posts / 0 new
Last post
vveconvco
Offline
Last seen: 1 year 2 months ago
Joined: Monday, August 20, 2012 - 14:29
Points: 47
scooter diagnostic not comunicating with Vectrix

I have scooter diagnostic version 2.0 on my laptop (windows seven). With the grid connect can/usb adapter connected and drivers installed, I have a continuous red light on the can/usb adapter. When I plug the adapter into the Vectrix, turn the bike on and initiate the scooter diagnostics program,
the general page comes up, but the red 'can inactive' indicator never goes green. Antiscab sent me an older version of dll file to install in windows 32 and to the scooter diag folder. I have installed these and still just a constant red light. If I use Pcan view, I can transmit and receive messages over the can/usb adapter, but not when I call up the scooter diagnostic. It's like the diagnostic program never attempts to comunicate with the bike. Does any one have a suggestion?

moccasin
moccasin's picture
Offline
Last seen: 4 years 11 months ago
Joined: Friday, July 11, 2008 - 19:05
Points: 494
Re: scooter diagnostic not comunicating with Vectrix

If your laptop is running 64 bit Windows 7, you may never get it to work. You may have to borrow someone's XP or possibly 32 bit Win7 to get results.

vveconvco
Offline
Last seen: 1 year 2 months ago
Joined: Monday, August 20, 2012 - 14:29
Points: 47
Re: scooter diagnostic not comunicating with Vectrix

Thanks for the reply. I tried using a laptop with XP and it worked.

Peter Faulkner
Offline
Last seen: 4 years 7 months ago
Joined: Tuesday, July 15, 2014 - 12:17
Points: 84
Re: scooter diagnostic not comunicating with Vectrix

got all 18 LEAF cells balance charged to 8.3v (4.15 each pair) and hooked up. Started lap top (XP) and scooter diag, got Pcan lamp flashing, closed scooterdiag, connected to bike, turned on bike and restarted scooterdiag. Just battery and temp lights now flash on cluster and headlamp goes out.
Scooter diag Pcan bar stays red ... shut down computer, disconnected Pcan lead and turned off bike.
switched on bike and all systems seem fine, moved bike about 1 ft forward and back, lights horn indicators, brake light all functioning as they should. Battery indicator shows about 30-40% full bars.
At one stage I did notice "CAN bus" message displayed at the bottom of the left hand dial .It appears that the bike is seeing the PCAN but the computer not seeing the bike . Have not yet connected charger (ESD) to the bike.
Not sure what to do next and don't want to mess it up by doing something stupid/wrong. Any advice?

Peter Faulkner
Offline
Last seen: 4 years 7 months ago
Joined: Tuesday, July 15, 2014 - 12:17
Points: 84
Re: scooter diagnostic not comunicating with Vectrix

PS Fans and Batt Temp sensors removed and no BMS, 200 amp fuse fitted.

Peter Faulkner
Offline
Last seen: 4 years 7 months ago
Joined: Tuesday, July 15, 2014 - 12:17
Points: 84
Re: scooter diagnostic not comunicating with Vectrix

racking my brains to think of anything. The only thing that might offer an option is about 5 years ago I had a 3g wifi dongle that needed a 64bit driver, could that be causing a conflict on the comms side?

JimmyB
Offline
Last seen: 2 years 11 months ago
Joined: Thursday, February 23, 2012 - 16:57
Points: 252
Re: scooter diagnostic not comunicating with Vectrix

It does appear to be quite a fickle piece of software. I ended up doing a fresh XP install on an old laptop just to get it to work.

Kocho
Offline
Last seen: 3 years 3 weeks ago
Joined: Friday, March 21, 2014 - 21:05
Points: 488
Re: scooter diagnostic not comunicating with Vectrix

If your laptop is running 64 bit Windows 7, you may never get it to work. You may have to borrow someone's XP or possibly 32 bit Win7 to get results.

Not quite. I run it on Win 7 64 and, after I changed 2 DLLs, it works just fine.

Below is what I sent to the Laird to include if he wants with his instructions going forward. Hope it will help here too:

"To help the other guy in the US (if he's having the same issue), here are the two problems I encountered with the software and how I resolved them. Note that I use a Windows 7, Service Pack 1, 64 bit version, but I don't think that was related - would have had the same issues on XP I suspect.

(1) Following your installation instructions to the letter, all was good until and including installing the PEAK drivers so my laptop would see the CANbus adapter (solid red light on the adapter). Problem was that I could not get the ScooterDiag program to run. I got an error message that said that the "msvcp71.dll" was missing. After some google time, it turns out this is some Microsoft-provided library that could be coped from other locations on the computer. This I did - just searched my hard drive for it and found several versions of it. I used on that was in the folder for some camera software that I had on my computer - copied that and pasted it in the ScooterDiag folder where the scooterdiag.exe is. There is already a similarly named file there, "msvcr71.dll", which I did not touch. At this point, the ScooterDiag would start without errors.

(2) The ScooterDiag was not seeing the CANbus - red in the status window. On Visiforvoltage I had seen a thread about that issue and the solution there worked for me too:

(a) in the ScooterDiag folder there should be a PCAN_USB.dll. rename that to PCAN_USB_old.dll.

(b) Get a different version of it from the PEAK web site and save it in the ScooterDiag folder where the renamed DLL is. The address to get it from is this: http://www.peak-system.com/produktcd/Develop/PC%20interfaces/Windows/PCAN-Light%20API/Win32/PCAN_USB.dll That's it - now the software shows green in the status area and sees the CANBus.

Peter Faulkner
Offline
Last seen: 4 years 7 months ago
Joined: Tuesday, July 15, 2014 - 12:17
Points: 84
Re: scooter diagnostic not comunicating with Vectrix

Thanks Kocho,

I will try the second, my scooter diag is opening fine, just need to get the red to green!! will report back!

Peter

Peter Faulkner
Offline
Last seen: 4 years 7 months ago
Joined: Tuesday, July 15, 2014 - 12:17
Points: 84
Re: scooter diagnostic not comunicating with Vectrix

Tried new Pcanbus .dll file and now I have the opposite problem, red light flashes, scooter diag opens, green box, readings display on scooterdiag, However now the Bike now does not recognise Canbus mode( NO CANBUS display on Left instrument!)!! and so new firmware will not upload/transfer and scooterdiag shuts down!!

Peter Faulkner
Offline
Last seen: 4 years 7 months ago
Joined: Tuesday, July 15, 2014 - 12:17
Points: 84
Re: scooter diagnostic not comunicating with Vectrix

Gave up with old XP computer and went with Windows 7 Laptop as per Kocho advice above... all new Laird firmware loaded sweetly!! Just need to sort out rear lamp/brake light not working, everything else works perfectly. Range shows 93 Miles. Only 2 bars but this will fix with discharge and a fresh charge apparently!

Really pleased and thanks to all for help, advice and goodwill!

Peter

JimmyB
Offline
Last seen: 2 years 11 months ago
Joined: Thursday, February 23, 2012 - 16:57
Points: 252
Re: scooter diagnostic not comunicating with Vectrix

Only 2 bars but this will fix with discharge and a fresh charge apparently!

You can also just set the gauge to 'full' using ScooterDiag :)

Log in or register to post comments


Who's online

There are currently 0 users online.

Who's new

  • TBS
  • Bill Haslam
  • ugbest
  • kevinclements
  • NorseSkorpio

Customize This