yellow wrench, canbus error, won't go away

1 post / 0 new
Gedrod
Offline
Last seen: 7 years 1 month ago
Joined: Friday, September 23, 2011 - 19:26
Points: 26
yellow wrench, canbus error, won't go away

Hi all,

I hope someone can help me with some insights into a problem.

I bought a 2007 Vectrix with a burnt out motor controller a last year and a mate has fixed it for me - he is an electrical engineer and also owns a vectrix. The batteries were very flat (2.2v) and the same mate also brought over an external charger to get the process started. I have since charged the bike on its own charger for 8-10 hours to the point that it switched itself off twice, the gauge is full and the voltage is showing 148.

The problem is that the yellow wrench shows while the bike is charging and, when I start the bike up, it goes through a normal boot up and then the yellow wrench and the canbus error come on 1-2 seconds after boot and then stay.

There is a video here - http://youtu.be/nfQVqQqxCek and a photo of the dash during charging here

When it is in this state the headlight is not on, the horn doesn't work, etc. I have tried start up with the side stand up and down - no difference and the side stand light doesn't show. I have tried rolling the bike around the shed to see if it was a "motor indexing issue", no luck. Interestingly if I roll it backwards quickly the reverse light on the dash come on.

I have tried starting it about 30-40 times either in quick succession or with a wait between tries over a coupe of days now. I have also left the bike on for over an hour, but no change.

All other reports in this forum say that this is a temporary annoyance, but this is crippling the bike.

Any help, thoughts or probing questions greatly appreciated.

Cheers


Who's online

There are currently 0 users online.

Who's new

  • MariahDouglas
  • venhon
  • cminter
  • Robert Feagley
  • yomen22

Support V is for Voltage