No Brake or Tail Light

14 posts / 0 new
Last post
Aircon
Offline
Last seen: 4 months 2 days ago
Joined: Wednesday, December 23, 2009 - 00:55
Points: 519
No Brake or Tail Light

Hi Guys,

I've read the collaborative handbook, but it may as well be in chinese to me.

My tail/brake light has stopped working. If there's anyone in Melbourne Australia who can help me fix it, please contact me either via PM on here or 0407 311 218.

Thanks in advance.

Peter

Aircon
Offline
Last seen: 4 months 2 days ago
Joined: Wednesday, December 23, 2009 - 00:55
Points: 519
Re: No Brake or Tail Light

I should add that my indicator lights, head lights, luggage compartment light, dash lights and licence plate light are all working, as well as the cigarette lighter socket.

MEroller
MEroller's picture
Offline
Last seen: 6 months 4 weeks ago
Joined: Monday, September 26, 2011 - 09:24
Points: 847
Re: No Brake or Tail Light

Did the electrical connector of rear lights come off? As both tail and brake lights are not working that seems to me to be the most obvious first thing to check ;-)

My rides:
2017 Zero S ZF6.5 11kW, erider Thunder 5kW

BLUESTREAK
Offline
Last seen: 1 year 5 months ago
Joined: Sunday, November 15, 2009 - 19:55
Points: 282
Re: No Brake or Tail Light

Your tail light and brake light use the same bulbs with only one led element in each, so if the connector plug it still hooked up you most likely have a burned out tail light. there is a good many commets on here about the reason the tail and brake lights burn out is because people have a habit of grabing the left brake leaver as soon as they turn on the key switch and the on-board 12 volt convertor hasen't had enough time to power up properly and it starves the tail light for juice and burns out. I don't have time now to look up the comments but will try later when I have more time. ps.( if people would wait for about 6-8 seconds after turning on the key before squezing the brake leavers thats enough time for the convertor to fully power up.

Aircon
Offline
Last seen: 4 months 2 days ago
Joined: Wednesday, December 23, 2009 - 00:55
Points: 519
Re: No Brake or Tail Light

Your tail light and brake light use the same bulbs with only one led element in each, so if the connector plug it still hooked up you most likely have a burned out tail light. there is a good many commets on here about the reason the tail and brake lights burn out is because people have a habit of grabing the left brake leaver as soon as they turn on the key switch and the on-board 12 volt convertor hasen't had enough time to power up properly and it starves the tail light for juice and burns out. I don't have time now to look up the comments but will try later when I have more time. ps.( if people would wait for about 6-8 seconds after turning on the key before squezing the brake leavers thats enough time for the convertor to fully power up.

That's interesting. I admit that I usually have it 'started' and I'm moving before the thing even stops booting up and before the headlight comes on. That doesn't help me fix it, but it might help make sure it doesn't happen again. Thanks.

BLUESTREAK
Offline
Last seen: 1 year 5 months ago
Joined: Sunday, November 15, 2009 - 19:55
Points: 282
Re: No Brake or Tail Light

HI AIRCON, if you can access the cable that plugs into the tail light you can test the plug with a 12 volt led light that has (2) wires coming out the, the tail light plug has (3) wires coming out, (1) is a ground-(1) is tail light and (1) is brake light, turn on switch and plug in 12 volt small led light keep moving the wires until you get it to light up and that will be the tail light power, take a plastic zip-tie and squezze the brake leaver handel and hold it down then keep moving the 12 volt led wires around until the led shows much brighter the the other tail light is. you can find the hot and ground wires by testing the small 12 volt led on any 12volt battery.and mark the hot and ground wires. this will tell you if the 12 volt vectrix electric system is ok then you will know if it's the rear tail light or if it's the 12 vectric electrial system. hope this helps. COOPER.P.S. LET ME KNOW IF YOU HAVE NEVER TAKEN THE TAIL LIGHT OFF THE BACK OF THE BIKE. BYE.

heathyoung
Offline
Last seen: 3 years 2 months ago
Joined: Wednesday, July 27, 2011 - 21:11
Points: 90
Re: No Brake or Tail Light

It will be the MOSFET in the boost converter for the tail-light. Its a surface mount unit that needs to be replaced.

I've done a couple, I think I may have a board I can do for you as an exchange. Not VIC but NSW.

ElectricLou
ElectricLou's picture
Offline
Last seen: 1 month 3 weeks ago
Joined: Wednesday, January 9, 2008 - 16:11
Points: 59
Re: No Brake or Tail Light

I have a working tail light for sale if you need it.

R
R's picture
Offline
Last seen: 2 weeks 5 days ago
Joined: Thursday, June 18, 2009 - 09:46
Points: 1758
Re: No Brake or Tail Light

Happened to me in 2007.
The problem was the 5v circuit inside the light. Any success?

Aircon
Offline
Last seen: 4 months 2 days ago
Joined: Wednesday, December 23, 2009 - 00:55
Points: 519
Re: No Brake or Tail Light

Happened to me in 2007.
The problem was the 5v circuit inside the light. Any success?

Lithiumvectrix bought a second hand light assembly from antiscab and installed it for me. The circuit board was probably zapped, and will be repaired and kept by Lithiumvectrix as a spare.

Thanks to both, my Vectrix lives on!

Aircon
Offline
Last seen: 4 months 2 days ago
Joined: Wednesday, December 23, 2009 - 00:55
Points: 519
Re: No Brake or Tail Light

........and it's broken again!

R
R's picture
Offline
Last seen: 2 weeks 5 days ago
Joined: Thursday, June 18, 2009 - 09:46
Points: 1758
Re: No Brake or Tail Light

and it's broken again!

If I remember correctly, all australian vectrix were send together inside the same ship. They are all from the same generation, therefore all tail lights have same defect. It may be a good idea to buy a newer spare:
http://www.shop.vectrixparts.com/tail-light-screws.html
Aircon
Offline
Last seen: 4 months 2 days ago
Joined: Wednesday, December 23, 2009 - 00:55
Points: 519
Re: No Brake or Tail Light

and it's broken again!

If I remember correctly, all australian vectrix were send together inside the same ship. They are all from the same generation, therefore all tail lights have same defect. It may be a good idea to buy a newer spare:
http://www.shop.vectrixparts.com/tail-light-screws.html

Defect?? What's this defect?

R
R's picture
Offline
Last seen: 2 weeks 5 days ago
Joined: Thursday, June 18, 2009 - 09:46
Points: 1758
Re: No Brake or Tail Light

Defect?? What's this defect?

I don't know. My 2007 vectrix had the tail light damaged by 2008. They told me the first ones were defective, they replaced it under warranty with newer one. 8 years after the newer tail light is still working.
Log in or register to post comments


Who's online

There are currently 0 users online.

Who's new

  • geoffb
  • Caribe
  • harmonline
  • ECCUK
  • E-scooter fan

Customize This