Semi-Urgent: Laird Mod and Lost Battery Bars with 2009 Vectrix (old charger) and Leaf batteries

5 posts / 0 new
Last post
mikesheiman
Offline
Last seen: 2 years 1 week ago
Joined: Monday, August 20, 2012 - 11:11
Points: 23
Semi-Urgent: Laird Mod and Lost Battery Bars with 2009 Vectrix (old charger) and Leaf batteries

I've been consistently losing bars on how much I can charge my Vectrix within the last week despite not losing pack voltage.

Yes, for example, I've ordered a USB to CAN cable, which hasn't arrived yet, to update the firmware for lithium.
A few questions:

*) Assuming my bike does not have a per-cell BMS, which it doesn't seem to, what firmware download/mods would you recommend (sans said BMS) for when my USB-to-CAN converter comes in?

*) About the losing bars (trying to figure out if this thing is still safe to drive to work)

Firstly, with the Laird firmware on a lithium powered bike, what does being stuck down to the first charger bar really mean? What will it do if that first bar dies.

I started with 12 after a charge when I bought the bike a few weeks ago.
Now I have about 5. Today when I drove back from work, I hit the dreaded first bar starting about 5 miles from home and made it home fine. However my voltmeter still said I had 143 volts of charge (this is nothing near 20% or less depletion, correct?) and after charging it has 5 bars at 146 volts (where it used to have more like 9-12 for that same voltage rating). And, even on the freeway at 60 mph, it never dipped under 140 volts.

Is this thing still safe to drive to work? Will the software cut the power dramatically if the first bar disappears, even if my voltmeter still says I'm ok?

Any other recommendations?

mikesheiman
Offline
Last seen: 2 years 1 week ago
Joined: Monday, August 20, 2012 - 11:11
Points: 23
Re: Semi-Urgent: Laird Mod and Lost Battery Bars with 2009 ...

To be clear, I checked under the hood and I have 18 Leaf modules, not 19.

antiscab
Offline
Last seen: 5 days 10 hours ago
Joined: Saturday, July 7, 2007 - 23:55
Points: 1686
Re: Semi-Urgent: Laird Mod and Lost Battery Bars with 2009 ...

most likely the fuel guage has lost sync, and just needs resetting

To be sure though, Check the voltages between each terminal - record them
Ideally do it after charging to 146v (should be full), and then again after a ride down to that last bar.

Daily Ride:
2007 Vectrix, modified with 42 x Thundersky 60Ah
Vectrix 60Ah Lithium Tyres Fuel Registration Insurance cycle analyst 2 x TC Charger & MC
conversion

LeftieBiker
Offline
Last seen: 1 year 1 week ago
Joined: Saturday, July 9, 2011 - 04:36
Points: 886
Re: Semi-Urgent: Laird Mod and Lost Battery Bars with 2009 ...

FWIW, I've had my 18 cell Leaf-Vectrix down to two charge bars, and it read 131-132 volts then. I think that what I wrote earlier is probably true: your bike's BMS isn't set correctly for the size pack (60AH) that you likely have. Either that or there is some major incompatibility between the firmware and the Leaf cells.

R
R's picture
Offline
Last seen: 2 weeks 5 days ago
Joined: Thursday, June 18, 2009 - 09:46
Points: 1758
Re: Semi-Urgent: Laird Mod and Lost Battery Bars with 2009 ...

The laird lives In Isle of man. I'm sure The laird Firmware works perfectly under Isle the man ambient temperature.

But in Barcelona The laird firmware consistently looses bars. In the end the bars will display your charging commute: if you drive 5 km and charge, You gauge will only display 1 bar.

After that last bar is lost, nothing will happen. Keep on driving and check voltage and km since last charge. I suggest you install framugas Ah counter, embedded inside his ICM firmware. Ah counter is the best thing you can trust on a prototype.

Log in or register to post comments


Who's online

There are currently 0 users online.

Who's new

  • Nicosp
  • VoltLurker
  • Greatwhite
  • Jhon Cook
  • seskas20

Customize This