Roth Motorboard 1500x

5 posts / 0 new
Last post
Last seen: 14 years 9 months ago
Joined: Friday, December 26, 2008 - 22:37
Points: 2
Roth Motorboard 1500x

I recently got one of these at a yard sale for 25.00 but it does not have a charger. Is there anything I could do to get this running again or should I just give up and throw it away. I can't find chargers anywhere.

Last seen: 12 years 9 months ago
Joined: Sunday, July 29, 2007 - 04:52
Points: 126
Re: Roth Motorboard 1500x

Have to tried Craigs list or if your willing to shell out 15-16 bucks plus shipping e-bay has got a good cheap selection. How many volts do you run and what size batteries?

Last seen: 14 years 8 months ago
Joined: Wednesday, January 14, 2009 - 13:34
Points: 3
Re: Roth Motorboard 1500x

If it is the same unit as what I saw recently, his 1500x has a custom Cyclon SLA that's made from 8 x 2V Hawker cells. In other words, 16V. 8aH capacity. Hopefully the battery is still good, because they are expensive due to custom shape (not the typical cylindrical Hawkers.

Last seen: 14 years 3 days ago
Joined: Thursday, October 30, 2008 - 09:10
Points: 63
Re: Roth Motorboard 1500x

The original batteries are probably cooked anyway. It shouldn't be too hard to slap together a NiCad or NiMH pack to fit that scooter. Whatever you do, don't throw it away. I'll pay you $25 plus reasonable shipping charges. :)

Last seen: 14 years 1 month ago
Joined: Monday, May 4, 2009 - 07:38
Points: 18
Re: Roth Motorboard 1500x

Hey All, I'm hoping someone here can help me out, I'm completely new to this, but found the group by doing a Google Search. I just purchased a Go Motorboard 2000X from Craig's List - mint condition, some wear on the tires and 2 batteries. It came with the original battery (which the guy said could still work) and what was supposed to be a brand new battery (never used). When I got home, I charged the "new" one about 8 hours + and got about 30 seconds worth of juice on it until I went from full battery to nothing. I am pretty sure that I charged it correctly. Just plug the battery in and connect the charger (I made sure that the scooter was off), right? I did this a few times throughout the past 2 days with both batteries, but get the same result on both.

Any suggestions? Ideas?

The guy who I bought it from seemed like a good guy and promised me that it worked. Is it possible that the "new battery" having never been used, never took to a charge and will never work? Is there a special way I have to charge these battery's, a sequence, or something that I'm missing.

What is my best bet in fixing this. Your suggestions above are something that I just am not capable of understanding, it all sounds a bit foreign to me (kudos to you guys). I read about upgrades to batteries (more power, longer life etc). Am i just too nice of a guy and took someone's word on it working.

I have had a hard time getting people who know about this stuff and or reaching Roth themselves.

Any help would be appreciated and helpful.

Thank you!

Log in or register to post comments

Who's online

There are currently 0 users online.

Who's new

  • Eyama
  • shakscouriers
  • piotrsad
  • smerritt036@gma...
  • DonnaStella123

Support V is for Voltage