The Son of WE Sucteam Returns

2 replies [Last post]
Joined: 05/22/2007
Points: 9

To recap: Having destroyed the controller that came with my Wilderness Energy BD-36 kit, I followed the advice of one of our esteemed group members (both here and in that "other" group) and ordered the ecrazyman/BD4833/Shenzhen Sucteam controller (48V 800Watt) through eBay. I tried to wire it up according to the recommendations that many of you have suggested to the numerous inqueries that have been made on this subject. Particularly, the + side of my battery pack plugs into the red controller wire and - into the black. Upon plugging in (just touching, I don't give it a full "slam them together") it's as if I have created a dead short; complete with vaporized metal and setting the plug plastic on fire. The motor moved not a whit. It behaves this way whether I have everything wired up or just the controller and the batteries. Have I acquired a DOA controller? Are there any tests of the controller I can perform with a simple VOM? Am I just doing something truly stupid out of sheer ignorance? Any help will be much appreciated at this juncture.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
dogman's picture
Joined: 04/29/2008
Points: 830
Re: The Son of WE Sucteam Returns

Dissapointing, but It doesn't sound to me like you did anything wrong.


Be the pack leader.
36 volt sla schwinn beach cruiser
36 volt lifepo4 mongoose mtb
24 volt sla + nicad EV Global

ZapGuy's picture
Joined: 10/08/2007
Points: 16
Re: The Son of WE Sucteam Returns

There were 2 wires that had to be connected (closing the circuit) for my ecrazyman/sucteam controller to run.
I put my keyswitch in to it -- but during my mock-up connections I just shoved a bent paperclip in to the female plug.
The plug was labeled as "power lock" -- looks like a couple of small wires, one red, one blue.

As far as the arc you get when connecting -- I've read that's "normal".
I think it's explained as a charge buildup in the controller (capacitors inside) that discharges when you connect the battery.
I get it too, and my controller is still working fine. I've just tried to limit the number of times I unplug/replug that thing. Scares me every time!

And you say the plug caught fire? Was that from a build-up of heat, or did the arc happen to ignite something?
Running 48v thru my Wilderness Energy 24v motor everything stays reasonably cool/warm.


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.


Who's new

  • CreditRepairMemphis
  • Scott2Hotty
  • dragoncat711
  • VITO
  • tomsqr94

Customize This