Schwinn Missle FS issue

5 posts / 0 new
Last post
Fluid72
Offline
Last seen: 8 years 3 months ago
Joined: Tuesday, May 4, 2010 - 09:32
Points: 21
Schwinn Missle FS issue

I purchased new battries about 1.5 years ago. I had no issues until just this season (after the winter) I removed the scooter from storage and it ran fine (a little slow but still ran) I laid it down in the back of my truck, took it to the shore, removed it from the truck, went to go and the scooter just sputtered and surged then just died I now get nothing. The charger says green for charged and the light on the scooter is green. Any ideas as to where to start?

thanks!!!!

strawhistle
Offline
Last seen: 2 years 8 months ago
Joined: Monday, March 10, 2008 - 08:43
Points: 340
Re: Schwinn Missle FS issue

Is the battery a lead acid battery? laying the battery on its side will let the acid out and leave the battery with no way to generate a voltage LaTeR

thank GOD I wake up above ground !!!!

Fluid72
Offline
Last seen: 8 years 3 months ago
Joined: Tuesday, May 4, 2010 - 09:32
Points: 21
Re: Schwinn Missle FS issue

Nope these are sealed scooter batteries.

e-doggies
e-doggies's picture
Offline
Last seen: 3 years 3 months ago
Joined: Sunday, December 30, 2007 - 10:15
Points: 280
Re: Schwinn Missle FS issue

...and the scooter just sputtered and surged then just died I now get nothing...

Sounds like it could be a connection issue. Do you have a voltmeter to help in diagnostics?

Start at the battery and check each connection. Work your way thru all the wiring all the way to the motor if necessary. Don't assume soldered joints are electrically well-connected. I've seen many Currie factory packs that are soldered at the tabs with a glob of "cold" solder on top, but still had a very wiggly connection. I'd also check the fuse and fuse holder carefully. Perhaps one or more connections rattled loose during the trip in your truck?

Please let us know what you find.

Huddy
Offline
Last seen: 5 years 2 months ago
Joined: Saturday, August 31, 2013 - 15:35
Points: 22
Re: Schwinn Missle FS issue

I just have just acquired 2 missle fs's. I purchesd new batteries and chargers. When I turn the scooter and have the light and plugged into the charger andopen up the throttle I grt power to the motors. however when I unplug the scooter from the charger, I have no power. Does the scooter have to be connected or does it run on 1. I have had no luck on finding a manual online. Am I doing something wrong with the power supply? Help thanks
-

Log in or register to post comments


Who's online

There are currently 0 users online.

Who's new

  • stephencurk
  • RightWayRoofing
  • Same Day Flower...
  • kaximbeider
  • MIAStLouisMO

Customize This