36 Volt Izip has lost power

5 posts / 0 new
Last post
blairg
blairg's picture
Offline
Last seen: 8 years 8 months ago
Joined: Saturday, March 21, 2009 - 06:03
Points: 50
36 Volt Izip has lost power

My Izip running on 36 volts was running great until recently when it has lost significant power. It now has the performance of about a 24 volt. Anybody have any ideas why ?

Thanks

marylandbob
Offline
Last seen: 1 year 4 months ago
Joined: Monday, June 22, 2009 - 12:24
Points: 524
Re: 36 Volt Izip has lost power

The batteries may be defective, allowing the voltage to drop below 33 volts under load of accelleration.---Connect a good voltmeter, and measure voltage WHILE OPERATING it, preferably on a slight UPHILL climb.--Bob
PS: A good 36 volt, lead-acid battery will measure over 41 volts at full charge completion. (12 volt lead-acid batteries will measure over 13.6 volts at full charge completion.--

Robert M. Curry

blairg
blairg's picture
Offline
Last seen: 8 years 8 months ago
Joined: Saturday, March 21, 2009 - 06:03
Points: 50
Re: 36 Volt Izip has lost power

Thanks for the suggestion but I have two lipo batteries and one lead acid and the performance seems to be the same on all of them.

Any more ideas ?

blairg
blairg's picture
Offline
Last seen: 8 years 8 months ago
Joined: Saturday, March 21, 2009 - 06:03
Points: 50
Re: 36 Volt Izip has lost power

I took it apart and it had overheated and was burnt

jateureka2
Offline
Last seen: 4 years 4 months ago
Joined: Wednesday, May 5, 2010 - 15:04
Points: 21
Re: 36 Volt Izip has lost power

What was 'it', the controller?

E-BIKES: [1]Ezee Sprint [2]Aprilia Enjoy Racing [3]eLation V2 e-bike kit on Trek 4100 [4]Bafang BBS01 kit on Fluid Momentum [5] FreeGo Hawk
E-SCOOTER: 2012 ZEV 7100 LR, 84V 60Ah nominal battery with 28 series GBS LFP cells
E-MOTORCYCLE: 2011 Zero S,

Log in or register to post comments


Who's online

There are currently 0 users online.

Who's new

  • CYBRTRKR
  • ericaturner
  • 2008VectrixForSale
  • flapjacksbestof
  • incomefun

Customize This